Excel

Excelde EĞERSAY – SATIRSAY Formülleri

Bir excel sayfasında sütun veya satırlardaki hücrelere girilen verileri türlerine göre saydırmak, gruplamak isteyebilir ve uzun tablolardan gerekli verileri rahatlıkla çekebiliriz.

Not: Microsoft Excel, bir koşula bağlı olan verilerinizi çözümlemek için kullanılabilecek ek fonksiyonları sağlar.

Belirli bir aralıktaki metin dizesini veya sayıyı esas alan bir toplamı hesaplamak için ETOPLA çalışma sayfası fonksiyonunu kullanın.

Belli bir satış miktarına göre satış primi verme gibi, bir koşula göre iki değerden birini veren bir formül oluşturmak için EĞER çalışma sayfası işlevini kullanın.

Boş olan veya boş olmayan hücreleri saymak için BAĞ_DEĞ_DOLU_SAY ve BOŞLUKSAY fonksiyonlarını kullanın.

Şimdi EĞERSAY ve SATIRSAY formüllerinin kullanımı ile ilgili örneklere geçelim. Örnek formülleri daha da geliştirerek kullanabilirsiniz.

Yukarıdaki resme göre A2 – A11 hücreleri arasındaki 10 satırlık sütundaki verilerle çalışma yapıyoruz.

1. Formülümüz alttaki gibi olacak. Böylelikle A2:A11 hücreleri arasında metin girilmiş hücrelerin sayısını alıyoruz. Üstteki resimde görüldüğü gibi 6 adet hücreye metin girmişiz. (Rakam girilen hücreleri saymaz)
=EĞERSAY(A2:A11;"*")

2. Formül alttaki şekilde. Bu formülle aralıktaki satırları sayıyoruz.
=SATIRSAY(A2:B11)

3. Formül alttaki şekilde. Böylelikle ilk önce satırların sayısını buluyoruz sonra metin girilmiş hücreleri sayarak farkını allıyoruz. Sonuçta boş satır sayınını alıyoruz.

Bu şekilde örneğin; bir sınıf listesinde sınava girmeyen öğrenci sayısını tespit edebiliriz.
=SATIRSAY(A2:B11)-EĞERSAY(A2:A11;"*")

4. Formül alttaki şekilde. Bu şekilde uzun bir sütunda bulunan herhangi bir kelime sayısını alabiliriz. Örneğin kız öğrencilerin sayısı gibi.
=EĞERSAY(A2:A11;"=elma")

5. Formül alttaki şekilde. Yukarıdaki formüle bir ek yaptık sadece. Elmalarla birlikte Armutların sayısını da aldık. Bu şekilde eklemeler yapabilirsiniz.
=EĞERSAY(A2:A11;"elma")+EĞERSAY(A2:A11;"armut")

YoRuMSuZ

Asıl mesleği eğitim olup internet ortamında hobi amaçlı yayınladığı sitelerle kullanıcılara doğru bilgileri ulaştırmayı hedeflemektedir...

İlgili içerikler

108 Yorum

  1. Merhaba,

    Alt alta iki hücre arasındaki farklılığı saydırmak istiyorum.

    Örneğin; A2=Ozancan Coşkun, B2= Ozancan Coskun

    Farklı harf “s” harfi. Saydırınca da 1 çıkacak. Bunu nasıl yapabileceğim konusunda bir fikriniz var mı?

    Çok teşekkürler.

    1. Eda, Excelde boş hücrelerin sayısını birkaç şekilde almak mümkün. Yine bir önceki örnekte B1-B10 sütun aralığında not girilmemiş boş hücrelerin sayısını şu şekilde bulabilirsin.

      =EĞERSAY(B1:B10;"")
      =BOŞLUKSAY(B1:B10)

      Örneğin yukarıda verdiğim ilk formülde “” işaretleri arasına 0(sıfır) yazarsanız 0 olan hücreleri sayar.

  2. MERHABALAR ACİL YARDIM GEREK SORUM ŞU;
    BAŞARILI KIZ ÖĞRENCİ SAYISI
    50 DEN YÜKSEK BAŞARILI OLCAK

    1. Örnek olarak A sütununda Öğrenci isimleri, B sütununda notlar olsun. B1-B10 sütununa kadar 50 yüksek puan alanların sayısın aşağıdaki formülle bulabiliriz.
      =EĞERSAY(B1:B10;">50")

  3. slm
    benim bi sorum olacak uğraştım ama yapamadım ben excelde puantaş tutuyorum örnek
    ahmet (raporlu)
    mehmet(izinli)
    kazım(raporlu)…. gibi
    şimdi ben bunları raporlu olanlar ayrı satırda sayı olarak izinli olanlar ayrı satırda sayı olarak toplama şansım varmı. bu raporlu ve izinlilein hücre yerleri sürekli değişiyor sabit hücrede değiller

  4. TARİH Başlama Saati /Çıkış Saati /Yemek Saati /Net Çalışma Saati / Normal Mesai Toplamı /Fazla Mesai Toplamı
    Pazar 08:00:00 17:00:00 01:00:00 08:00:00 08:00 16:00:00
    Pazartesi 08:00:00 12:00:00 01:00:00 04:00:00 04:00 0:00:00
    Salı 08:00:00 13:00:00 01:00:00 04:00:00 04:00 0:00:00
    Çarşamba 08:00:00 19:00:00 01:00:00 10:00:00 08:00 3:00:00
    Perşembe 10:30:00 17:00:00 01:00:00 05:30:00 05:30 0:00:00
    Cuma 10:30:00 20:00:00 01:00:00 08:30:00 08:00 0:45:00
    Cumartesi 13:00:00 17:00:00 01:00:00 04:00:00 04:00 0:00:00
    Pazar 00:00:00 08:00 0:00:00
    Pazartesi 14:00:00 17:00:00 01:00:00 03:00:00 03:00 0:00:00

    Net Çalışma Saati; tam gün çalışmışsa, yemek saatini düştükten sonra çalıştığı tam saati versin. Normal Mesai Toplamına; Günlük Çalışma saati 8 saat olduğu için,fazla mesai’yi düşürüp normal mesai saat toplamını yani mesaisiz çalışma saatini versin. Fazla Mesai Toplamı; Normal Mesai Toplamından kalan saatin, Hafta içi ise %50 hesaplamasını yapsın, pazar günü ise %100 hesaplamasını yapıp fazla mesai saat toplamını atsın.

    Eksik Giriş Çıkış Saatlerinde Uygulanması Gereken Formül; Giriş Saati; 8:00 – Çıkış Saati; 17:00…… Yalnız kişi; saat 08 – 12 arasında giriş yapmışsa yemek saatini çıkartıp Net Çalışma Saatini Hesaplasın. Kişi; saat 13 – 17 arasında giriş yapmışsa yemek saatini toplayıp Net Çalışma Saatini Hesaplasın. kişinin çıkış saati; saat 12 ve 12’den küçükse yemek saatini toplayıp Net Çalışma Saatini Hesaplasın.çıkış saati; saat 13 ve 13’den büyükse yemek saatini çıkartıp Net Çalışma Saatini Hesaplasın.

    Anlatmış olduğum şekilde formülleri yazarak yardımcı olabilirmisiniz…. Acil !!!!!

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Başa dön tuşu