Excel

EĞERSAY formülü ile tablodaki verileri sayma

EĞERSAY işlevi, belirtilen kritere uyan hücre sayısını bulmak için kullanılır. Örnek olarak bir müşteri listesinde bir ürünün, bir ülkenin veya şehrin kaç kez geçtiğini bulmak için kullanılabilir.

Kullanım alanı çok fazla olmasa da büyük tablolarda sayısal veri sonuçlarına ulaşmak için oldukça kullanışlı bir işlevi yerine getirmektedir. Excel tablolarındaki boş ve dolu hücrelerin sayısını bulmak için BURADAKİ EĞERSAY işlevinin kullanıldığı konuya göz atabilirsiniz.

EĞERSAY fonksiyonu yazım formatı aşağıdaki gibidir.

=EĞERSAY(aralık; ölçüt)

İlgili içerikler

Gelelim bu işlevin pratik kullanım örneklerine… Bu örnekte örneklerin altında yer alan tablodaki veriler kullanılacaktır.

Tabloya göre;

Kişi sayısı:  Not: Aşağıdaki şekilde sayıyı bulmak için kullandığımız EĞERSAY işlevi rakam girilmiş hücreleri saymaz.

=EĞERSAY(A2:A11;"*")

Erkeklerin sayısı: Cinsiyet sütununda sadece E harflerini saydırmak için aşağıdaki formülü kullanın.

=EĞERSAY(B2:B11;"E")

Matematik branşı: Branş adı yerine joker karakter kullanarak “Mat*” yazmak yeterlidir. EĞERSAY işlevinde ifadenin sonunda veya başında * joker işaretini kullanabilirsiniz.

=EĞERSAY(C2:C11;"Matematik")

70’ten büyük notların sayısı: >70 şeklindeki giriş, 70’ten büyük olan notların sayısını verecektir.

=EĞERSAY(D2:D11;">70")

70 ve 70’ten büyük notların sayısı: Yukarıdaki formülün 70’i de kapsaması için = işaretini de ekliyoruz.

=EĞERSAY(D2:D11;">=70")

A ile başlayan illerin sayısı: Joker kullanımına örnek. Eğer “*A*” şeklinde kullanırsanız adında A geçen tüm illerin sayısını, “*a” şeklinde kullanırsanız A ile biten illerin sayısını bulabilirsiniz.

=EĞERSAY(E2:E11;"A*")

60 – 80 arasında: Belirtilen rakamların arasındaki sayıları bulmak için ÇOKEĞERSAY işlevini kullanabilirsiniz.

=ÇOKEĞERSAY(D2:D11;">60";D2:D11;"<80")

Alternatif sayma, 60 – 80 arasında: Yukarıdaki formülün alternatifi. ÇOKEĞERSAY yerine TOPLA.ÇARPIM işlevi ile de aynı sonuca ulaşabilirsiniz.

=TOPLA.ÇARPIM((D2:D11>60)*(D2:D11<80))
EĞERSAY formül kullanımı

2 Yorum

  1. Eğersay işlevini herkesin anlayacağı şekilde anlatılması isabetli olmuş. Bazen bu tür konular arapsaçına dolduruluyor bir şey anlaşılmıyor

  2. Ne kadar teşekkür etsem azdır. Eğersay formülü ile uzun bir tablodaki verileri almakta hiç zorlanmadım.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Başa dön tuşu